OBDII Scan Tool FTW!

A buddy of mine on Mechanics.SE is doing an experiment to see if there can be a general rule of thumb applied to volumetric efficiency (VE) on engines running at idle. To me this is a really cool experiment to garner some real world results.

I originally was using my Innova 3160 hand held scanner which reads live data from the engine. After returning the results, my buddy told me the lbs/min reading was just too granular. He wanted to see if I could get a better reading by doing grams/sec. The scanner doesn’t have an option to change the units, so I went Amazon and found a Bluetooth reader which would work with my Samsung Galaxy S7 phone. The one I found was this one:

I’m always a little apprehensive about purchasing cheap products like this, but since it was only about $22, I decided it wasn’t going to leave a big dent in my wallet. Luckily the reader works perfectly and I’m very pleased with the purchase.

I wasn’t very pleased with the USPS, though. We order most everything on Amazon with Prime. With Prime, you get complimentary 2-day shipping … well, you’re supposed to. While I shouldn’t complain too much, it actually took it three business days to get here (five actual days because I ordered on the weekend). This wasn’t a problem with Amazon, but rather with the US Postal Service. They don’t seem to like to abide by Amazon’s two day shipping very well. It’s more like “2 days or whenever we decide to get it to you“.

I downloaded the app Torque Lite for my phone. It works okay for the most part. There are a few design issues I’d like to have a hack at, but it does work. The Mass Air Flow (MAF) output for it is in grams/second, so is inline with what my buddy needs for his experiment. There are a ton of things you can display through the app, along with seven (or is it nine??) screens you can display stuff on. Most of the readings are pretty rudimentary, but it does work.

All-in-all, it works pretty good. I’m happy with the purchase. I’m thinking about delving into programming an app for the Android which will allow me to better customize what I want the app to do, rather than utilize what’s on the market. I got the idea from a different guy on Mechanics.SE. He does this type of work all the time. I know I have the brainpower to do something like this as I’ve done scripting/programming in the past. It would just be a pretty serious ramp up in my skills to make it happen. I guess time will tell if I can. There’s nothing I need to do on an emergency basis to get it done, so if it takes a few weeks, months, or years, it’s not a big deal. If I do do something like this, you can rest assured I’ll throw something uper … post a blog entry about it.

Radiation Overload

The son and I did a little work on his car today. I’m still fed up with it not starting, but I was able to verify all of the fuses are in good shape, to include the fusible link. I need to look in a different direction to figure out why it isn’t starting. I still think there are a ton of grounds which I need to add into different areas, then it will probably run like a big dog and I’ll be ready to kick it out of the garage.

Something else we worked on today was getting the radiator put into the front end. We decided to go a little bit different route than we were before. Here’s a picture of the front end as it sits right now:

You’ll notice a big chunk taken out of the front bumper support. The reason for this is we decided we are going to locate the radiator to the front of the piece of angle iron. This will push the radiator forward enough we’ll be able to fit the fans in behind it with room to spare. This will leave them in the puller mode instead of pusher fans. We’ll have to trim the front bumper and the grill won’t fit without heavy modification, but it will work better in the long run. One of the main things it will do is give me more space to put the top radiator hose in place. Before deciding to move it forward, the upper radiator outlet was almost touching the cam belt cover. Where it will be at now will give use plenty of room.

The plan with it is to weld a piece of angle iron (just visible at the top left side of the image) onto the bumper support. This will tie the two sides of the bumper support together while giving us the room we need to make it work. Next, I’ll be welding two tabs along the bottom of the core support where the two shiney spots are at. You can see the metal tabs just below and to the left of the gloves at the top center of the image. After the tabs are welded into place, I’ll need to mark and drill holes in them so I can place the locating pins in the bottom of the radiator into them. I want to get some rubber pieces for the top, but I plan on cutting down the tabs on the top of the radiator, drilling them, then bolting it to the top piece of angle iron. This should leave the radiator very secure and in good shape.

One last thing to look at in the image. If you look really close you’ll see a round object with a blue cap on it. This is the recovery tank for the car. It’s out of some type of VW … a Jetta, IIRC. Where it’s sitting at is where we are going to mount it. It will fit just right in there where the A/C compressor was supposed to be at. I think it will work just awesomely there. I’ll be able to create a bracket to hang it off of right there without too much of an issue. We’ll have to get a T to put into the heater hose line, run hose from the bottom of it back to the heater hose, plus install a small line from the radiator to the small line on the recovery tank. The only prerequisite with the recovery tank is it needs to be higher than the rest of the cooling system. This will make a good home for it.

While the Impreza still isn’t running, it is a little bit closer. I’m have hopes things will continue to progress. I think I can get the welding out of the road tomorrow, at least for the cooling system portion of the build. Things are a little bit closer and I’m happy with the progress.

Head Gasket Replacement for Misfire Codes?

I received an email from a lady who was referred to me by a mutual friend. The email went something like this:

“[Mutual friend] gave me your name and said you may be able to help us with a repair we need on our Honda. It’s a 2003 Honda Civic with 161,000 miles on it and it idles really rough. We took it to meineke and they said the head gasket needs to be replaced. Is that something you could help us with? If so, what would the charge be?”

In response, I said:

“I possibly could, if that is really what the problem is. Let me know when we could talk?”

She sent me her phone number and I called when specified. She stated they had diagnosed a misfire code, had subsequently changed out the spark plugs (not a bad thought), but the misfire continued to happen. Meineke then told them they’d need to change out the head gasket, but was unsure if it would solve the issue. The cost of the head gasket replacement: $1800. I ran through some other over the phone diagnostic questions:

  • Q: Does the oil look milky like chocolate milk? A: I don’t think so.
  • Q: What were the exact codes? A: They didn’t tell us, just that there was a misfire present.

At this point I asked if I could come over and take a look at the car. I was pretty sure the car wasn’t in need of a head gasket and that someone at Meineke was trying to have a good Christmas at the expense of this couple.

When I got to the car, I read the codes. Sure enough, there were misfire codes for cylinders 2&3, along with some other general misfire codes (which is not unusual). I swapped out the #1 and #2 coils and what do you know, the misfire was no on the #1 cylinder. Diagnosis: Bad Coils. With 161k on the car, this isn’t hard to imagine or diagnose. I had looked online at my favorite online parts retailer when I was first contacted, RockAuto.com, and discovered the parts would be about $25/coil. I looked on Advance Auto. They wanted $56/coil. I suggested to the couple if they didn’t need the car they should order them online, which they heartily agreed with. I also showed them they could find a 5% discount code really easily for RockAuto, which almost paid for the shipping. RockAuto stated it should take 3-4 business days for the parts to get to their house. I took the owner outside and showed him exactly what to do to change out the coils, which two coils to replace, and that he should do it one at a time. This is really a simple job which is actually easier than changing out the spark plugs which the owner had done before.

Bottom line, as long as my diagnostics are accurate, the vehicle owner has saved a ton of money. Realistically, their 2003 Honda would not be worth the $1800 quoted for the job, then the job wouldn’t have fixed the issue in the first place. This couple decided to get a second opinion and in my eyes, this paid off big time. If you go to a shop and they tell you there is a big cost involved, don’t necessarily just buy off on it and take their word for it. If a shop tells you they want to charge you a large amount for a job, yet they don’t know if it will solve the issue, you really need to get a second opinion. Especially if it’s a muffler shop talking about big engine repairs which definitely doesn’t fall into their bailiwick.

You’re FIRED!

Our President Elect is known for these words, but really, I’m referring to the awesome sound of an EG33 firing for the first time on open headers! YES! It fired! I am VERY pleased, to say the least. I’ll recap …

If you’ve read any of my other blog entries, you know I’ve had the engine in for some time now, but I’ve been unable to get it to start. I’d tried several things, but nothing was working. My son finally hooked me up with a FaceBook page. After a couple of days I was able to get on there and start asking questions. A couple of guys there took some time to get me thinking about things.

There are three things you need in order for an engine to run (some would argue there are four … get to that in a bit). The three things are: air, fuel, ignition. The “fourth” thing some would complain to me is “compression”. My argument about compression is … if everything is mechanically right with the engine, you’ll have compression. An engine could conceivably run without compression. Compression just allows it to run more efficiently … but I digress.

I knew there was air … that’s a given because it’s there … all around you. As long as it’s sucking it in, you’ve got air. The second thing was fuel. I knew the fuel pump was running, so that shouldn’t be an issue either. The third thing is ignition … you need spark. On checking the spark plug and the coil, there wasn’t any spark. I back probed the coil and discovered I didn’t have any power at the coil … well, none to speak of as it read out to have ~.5vdc with the key on. You should actually see battery voltage with the key on. On the wiring diagram I saw where the coils attached to the connectors of the wiring harness at the back of the engine. The connector is B4 in the Subaru schematics. The two power wires for the coils attach to pins 3 and 6. I traced the wires back from the connector and what do you know I found … they weren’t attached to anything. Luckily I was anal enough not to have cut these off, but had left them in the bulk of the wiring harness which was rather “attached” to the rest of it. I’m glad I did, as I just attached them to the switched power I’m using for the other stuff. While I was at it, I also ran a sure ground to the igniter as the ground on it seemed a little flaky. I ensured the fuel pump was energized, then turned the key and it fired right up. I was completely surprised, but thrilled at the same time. Absolutely fired up … I was, that is! After a couple months of farting around with this thing, it lives.

Here’s a short video of the second firing:

Yes, folks, open headers are really loud! Nothing like the sound of an engine coming to life which has been dead for so long.

I still have one small issue I need to work out. The fuel pump is still intermittent. I don’t know why, but it only runs if I ground the fuel pump relay manually … this means the ECU isn’t getting a good ground somewhere, or if it isn’t switching it for some reason. Doesn’t matter. Something is wrong, so I’ll have to figure it out.  I also need to shore up all the wiring. As you can tell in the video, there’s wires strung all over the place. It’s a mess in the cabin, but right now it’s a good mess! I can deal with it now I know the engine runs.

The two big things left to do on the car is get the exhaust put together and get the cooling system sorted. The exhaust is going to be an amalgamation of the EG33 exhaust to just past the cats where it Y’s together, into the Impreza exhaust which will run it out the back of the car. It should work rather slick. The other thing which is left is the cooling. We have a Saab 900 radiator and two 10″ electric fans. Getting it all in will be problematic, but should work with a little bit of fabrication. I bought some 1″ angle iron for just such an occasion.

All-in-all, it was a productive night. I’m looking forward to getting it back on the road, but this was definitely a giant leap for the process! I’ll be back with more news as it presents itself. Until then, watch the video again … gives me goosebumps just thinking about it.

Back To Basics … and an output diagram.

I got the new ECU in and discovered the old one wasn’t bad. As I plugged in the new ECU, I had the same issue … the fuel pump wasn’t kicking on when I turned the key to the on position. My heart about fell out on the floor. Like I said before, this is R&R wrenching and I do not like it. I then started playing with the wires on the ECU. Low and behold … the pump kicked on. Holy smokes. The problem was not with the ECU, but with the fuel pump relay wire coming from the ECU not making connection at the pin. I then pulled out the pin from the connector, played with it a little bit (read: used a pair of pliers on it to make it have a little better contact), re-pinned it in the connector, and have been rewarded with a consistently working fuel pump since then. Engine still isn’t starting, but the fuel pump runs! Yay, small victories! Even if your victories come after setbacks … argh.

I’ve decided to go back to the drawing board a little bit. I’ve found a couple of charts on RS25.com which will probably help. I’ve seen these charts before, but haven’t given them much mind until now. Yes, folks, I can be dense (enter: not seeing the forest for the trees cliche here). Here are the two charts I’m talking about:

42353853

42353893

What these two charts show is each of the important connections at the ECU and what their values should be with the ignition/engine in the off, on, and running positions. The plan for today is to go through each connection at the ECU with the key in the off and on positions, then back-probe the ECU to get each of the values from the pin. I’m hoping in doing so I’ll be able to figure out if something is not reading. It will be an arduous task, but I think it will provide results which may help me figure out why the engine isn’t starting.

Fried Turkey for Thanksgiving?

While we did have a fried turkey for Thanksgiving, I’m almost positive I’ve fried the ECU as well. Just to put anything aside, I’ve gone ahead and purchased another one off of eBay. I know this goes against everything I hold dear with regards to working on cars … as in … I do not do R&R (Remove & Replace) wrenching. There is no worse form of diagnostics. It always costs more money than you can afford. It’s really just wrenching at its lowest level without diagnostics. I guess I can say I’ve actually done some diagnostics, though. Let me explain what’s going on …

I’ve been troubleshooting the Impreza trying to get it to start. I found two plugs in the engine compartment which looked like they belonged together. Plugged them up and they snapped right into place with each other like a matched set … turned the key on and no longer heard the fuel pump kick on. I went around to the other side of the car where the ECU is at and you could smell the acrid smell of burnt electronics in the air. Yah, one of those heart sinking moments. I turned the key off and on again hoping I was just hearing things, but sure enough, no fuel pump. I went through and checked all of the fuses and couldn’t find any which were bad. I can ground the wire to the fuel pump relay and the pump kicks on just fine, therefore I know the relay and connection is just fine. The common denominator here is the ECU. I took the shell off of the ECU and you could smell it had a burnt electronics smell to it. I took the board off of the shell completely and did a complete once over on it. While I couldn’t pinpoint any fried capacitors, transistors, or resistors, something in there smelled burnt.

Since I’m about 95% sure I’ve fried the ECU, I went ahead and ordered it. Just one more thing I’ve had to purchase. While I’m a little stumped by why this thing won’t start in the first place, hopefully this will get me one step further towards the end goal of a rocket ship for my kiddo.

Sphincter says “What?”

I’m still working the issues, but no joy. I am able to get the Impreza to crank, but there’s no life in the engine. I can hear the fuel pump kick in. There is fuel in the tank. I haven’t checked the pressure at the fuel rail, but I’m assuming there is pressure there. There is power to the injectors (verified). I don’t think the ECU is getting a signal to fire anything. The plugs are dry. I did pull one out and cranked the engine. I didn’t see any fire at the plug, so I’m assuming there’s nothing there. The engine started prior to pulling it. This was on ether, as the fuel pump in the SVX wasn’t working. Since it was running on ether, it would mean the crank/cam sensors should be working providing input to the ECU and spark at the spark plugs. Still, I’ll be checking the crank/cam sensors as they are just hall effect sensors and should provide some type of electrical movement as the field is broken across them.

I’m going to try and get the DLC connector for the ECU hooked back up, or at least get wires ran for it so I can attach my code reader. This should (hopefully) give me some insight into what might or might not be happening in the ECU. I have heard rumor, though, that these Subarus didn’t have OBDI, but rather just the Subaru brand of engine management. I guess I’ll have to play with it and see if I can figure something out.

Wouldn’t you know it … I looked on Craig’s List today. Found an EJ22 for $450 out of a 96 Impreza with supposedly low miles … If I had only known …

The Flow Goes This Way

I haven’t gotten much done to the Impreza over the last few weeks. I’ve been working on a class for my Masters. I also spent most of a week out of town for work, so that didn’t help. Plus the release of TitanFall2 … too much fun and not enough time!

What I’ve been trying to figure out lately is how to get the wiring harness into the Impreza. There have been a few stumbling blocks. I was given some wiring diagrams for the Impreza which were okay, but they were B/W and hard to read. It was VERY hard to tell what the layout of the ECU connector was and the labeling of the wire colors was terrible. Luckily a guy on Stack Exchange provided me with some color ones, which are awesome. Here’s what they look like:

94gwwwgyes

Looking at the two images, the right side of the top one connects to the left side of the bottom one. The ECU plug shown in the diagram actually looks like this when disconnected:

20161106_122914

It’s actually upside down. Pin #1 is on the lower right side of the connector and runs across to pin #16, then continues down from there. I’ve found most of what I need to cull out of this to plug into the SVX ECU to make it work. We’ll see how it goes. I’m going to clip the wires I need off of the back of wiring harness (probably leave a pigtail) to connect. I’ll blog about it as I’m hoping to get the car started this weekend.

One of the other things I needed was a diode to fool the ECU into believing the “automatic” transmission is in park. Since the transmission in the Impreza is a standard shift, you have to include the diode in the mix so it will think it’s in either park or neutral. Without it, it thinks the transmission is in gear and that’s all she wrote … no cranking will occur. I was wondering what size of diode I’d need and where I’d be able to find one. Luckily, keeping the old wiring harness pays off. There just happens to be a pair of them already in the harness which you can use for this purpose. Here’s what they look like:

20161110_201149

I’m still unsure of how they go into what I’m doing. Not sure of the direction alignment. Not sure of a lot of things, but ultimately I’ll get it figured out.

Like I said, I’m hoping to get it started this weekend. I’ll blog about my endeavours later most likely :o)

Engine Installed

While my son was here over the weekend, we were pretty much able to get the engine installed all the way. The intake is now on and all the vacuum lines hooked up (or awaiting their home). The next big step is getting the radiator in, which is being quite a chore. We also started looking at the wiring.

For the radiator, I took the approach I’ve seen elsewhere, but cutting the core support at the top, then inserting 1″ angle iron in its place. This allows for a removable portion of the core support which allows for the radiator to go into and out of the engine bay with the engine in … at least that’s how the theory goes.

20161016_113159

Here is how the core support looked with the piece in there (note: I’d already cut it out, but wanted to show where it’d be).

20161016_113218

Here it is with it cut out. I angled the cut to allow more clearance for the radiator, yet not interfere with the support of the headlight. I was able to cut a piece of the angle iron to fit. I then drilled holes down through the core support and from the front back, right next to where the headlight will go in. I then marked where the holes would go on the angle iron and drilled them out with the drill press. I took this tap, which is an M6x1.0 (I believe) to create threads in the angle iron. This worked out really well.

20161016_123127

There is a reason you keep extra fasteners around after you tear something apart. You’ll find you’ll always need something. Today was no different. I was able to find several bolts which worked out perfectly for my needs.

20161016_122955

I then bolted the angle iron into place where the core support used to be.

20161016_123800

20161016_123818

It was amazing the amount of support bolting this into place makes. It firmed up the entire assembly, to include where the headlights go. It really amazed me.

We are still going to have to do some work getting the radiator into place. There are a couple of things to still work out. One of those is the radiator is still too close to the engine on the passenger side. The upper radiator connection sits precariously close to the engine. I’m not sure how we are going to get the hose to fit the upper connection and over to the engine. The lower connection will not be an issue. I’ll have to get some adapters to go from the 1.25″ on the radiator to the 1.5″ connection on the engine. I’ll need to get them for both the top and the bottom.

As it stands, things are coming together. There is still a ton of work to be done. We are still wondering where we are going to mount the EG33 ECU in the car. I have an idea we are going to gut the A/C core out of it’s box and mount it in there. I will then put some kind of barrier between the ECU and the where the air flow occurs inside the box. He won’t have A/C, but he’ll still have heat. The heat still uses this portion of the HVAC to traverse to the different parts of the vehicle. It’s all a trade off. Hopefully we won’t have any issues making happen.

Krazy Glue and You

I’m in the process of getting the top part of the intake manifold together on the EG33 so I can bolt it down and have that part done on it. It’s quite a chore with all of the vacuum lines they ran on the engine. Really, I guess there weren’t that many lines, but there are a few. My son was able to find this vacuum chart which helped a whole bunch. I had most of the lines figured out, but some I had the wrong idea for, so was able to adjust fire and figure some stuff out.received9510154771542021062

There were a couple of things I had to buy to put it together right. One of the things was the vacuum check valve (#8 one-way valve). I bought one of those cheap Dorman products you see in the “Help!” section of most of the popular parts chains. Paid $5 for it and it was worthless. I didn’t want to go buy another one as it would probably have the same issue. I didn’t want to purchase something off of Amazon and figure out if it was going to work or not (size wise), then it would take at least two days to get here even using Prime. I started wondering what I could use instead. Then it came to me. My daughter’s fish tank has check valves on the air lines going into the tank. This is used to keep the water from syphoning out of the tank and back down the air lines. I took one of hers out and tested it under vacuum (yah, I sucked on it). It held the vacuum like nobody’s business. I put her air lines back together and was on my way to Walmart. I picked two of them up for less than what it cost me for non-usable one from the parts store.

In the process of pulling the manifold off, I broke the Purge Control Solenoid Valve (#10). One of the nipples broke off of it because the lines are so stinking hard, things got broke. I looked around on the EJ22 to see if there was another one like it, but couldn’t find it (I believe it was bolted to the fender and the son removed it … never to be found again). I then looked online for a replacement I could buy. Yah, right. $110 for one. I again started thinking about how I could fix it. I figured out I could probably put a new nipple on there if I did it correctly. I found a butt adapter for the vacuum lines and cut one half off so there was a rather large flat portion I could use (large relative to the nipple itself). I then took the solenoid to my bench grinder and gently shaved off where the old one was broken from, making it very flat. I picked up a tube of Krazy Glue from the store and applied it to the nipple. Five seconds later it was bonded to the solenoid. Seems air tight as well. I’ll trade $2 for a tube of Krazy Glue any day of the week instead of dropping $110 on a new one. Krazy Glue FTW!

20161013_195448

Because we have to chop part of the core support out, I went down and bought some angle iron the other day. Cost $30 for a 20’x1″ length which they cut in half. I’m going to use this to rebuild the core support after we chop it. It will also support the radiator at the top. The bottom is held in by the two grommets used for the original radiator. We drilled a hole in the core support, then used a step drill to cut a much bigger hole. These bigger holes will support the old grommets and the radiator in just the right spot. I was really impressed with how the step bits I bought from Harbor Freight did, and the wonderful job of cutting the holes. I highly recommend them as a cheap but effective way to get the job done.

Since we will no longer have the core support across the top of the radiator, there will also no longer be a latch we can use. My son bought these instead.

20161013_161728

These are JDM, direct from Japan. Hood pin latches with locks in carbon fiber. I’ll have to cut some holes for them, then recess the lips so these will sit flush with the hood instead of sitting on top of them. They’d work if on top, but it would be ugly as sin. Cutting them flush will look a lot better. He said these were relatively cheap and there are better models. Even so, these should turn out okay as long as I can get them installed easily.

These will probably be some of the last things to get installed. Plenty other work ahead of them … like getting the engine running! I gotta get the engine back together first, like getting the vacuum lines completely sorted. There’s only a little bit more in that department, then I can slam the top part of the intake manifold back onto the engine and call it a day. Still lots to do. It’s a lot easier when my son is here to keep me motivated. If I’ve found nothing else in doing this project, it’s that I have an awesome son who I can work with. He even listens … that’s something I’d never seen before :o)